0

Closed

eliminare il parametro start/stop

description

MEGLIO LASCIARE COSI'
 
The start and stop of actions should be managed by two separate methods rather than a parametric one.
Will give a better interface.
Closed Feb 19, 2012 at 11:20 AM by ilPropheta

comments

wrote Nov 11, 2011 at 1:12 PM

Most of the actions implemented so far require to do a lot of similar things to start and stop. To avoid code duplication the internal implementation should remain as is, but should be called by the start/stop different routines. Lots of trouble for an "estetic" interface change? The current interface already "suggests" to factor things.

wrote Feb 19, 2012 at 11:20 AM

wrote Feb 2, 2013 at 2:59 AM

wrote May 13, 2013 at 7:25 PM